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1 Introduction
Octaga Player is a high performance, standards compliant 3D player which brings 
technical data to life on your computer. You can use Octaga Player to view and interact 
with 3D presentations, as well as to display standard image, video and audio files. It is 
both a standalone application and a plug-in you can use in your web pages, and display 
in most popular Internet browsers, as well as in Microsoft Office and PDF documents.

With Octaga Player, you can move, explore and navigate through any VRML or X3D 
scene.

Octaga Player complies with VRML and X3D standards. It has won wide acceptance, 
and is currently used by more than one million users. 

1.1 Purpose and scope of this manual
This manual provides information about how to use Octaga Player. The main focus is 
the standalone program, but you will also find information on how to use the web page 
plug-in. The manual shows you how to get started and how to make full use of the 
program. It also provides a troubleshooting guide.

Some features described in this manual are marked with the word “Pro”. These features 
are disabled in the free version of Octaga Player, but are enabled when you have 
bought and registered a license for the program.

1.2 New in Octaga Player 2.3
 64-bit versions of Octaga player is available for computers with 64-bit CPUs. 
 Improved navigation and user interface. 
 Improved rendering capabilities, including geometry shaders. 
 Smoother file operations due to  multithreaded loading. 
 Display encrypted content (EWRL).
 Site License Solution lets you use a web server to check if your network domain is 

registered. 
 Support for the Geospatial, HAnim and Networking components of the X3D 

standard. 
 Full Java and Ecmascript SAI support.
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2 Installation

1.3 Installing Octaga Player
To install Octaga Player, download and run OctagaPlayer.exe. The installation wizard 
will guide you through the setup process.

1.4 Uninstalling Octaga Player
To uninstall Octaga Player, start Add/Remove Programs in the Windows Control Panel. 
Select Octaga Player from the list of installed programs. Click Remove and follow the 
on-screen instructions.
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3 Getting started
1.5 Starting Octaga Player

To start Octaga Player double-click the Octaga Player icon on your desktop. You can 
also start the program by clicking the Start button on the desktop taskbar, and then 
select All Programs->Octaga Player->Octaga Player from the Start menu. 

When you start Octaga Player, an option window appears. This window is displayed 
until you purchase and register a license. In this window you can:

Launch. Press this button to start Octaga Player. You can display and interact with 3D 
presentations, but a number of functions are disabled.

Buy Now. Press this button to go to Octaga’s web store, where you can buy a license.

Register. When you have bought your license, it must be registered with Octaga. When 
you have registered your license, you can use all Octaga Player’s advanced features.

When you have purchased your license and registered it with Octaga, the program 
starts without this option window.

See section 3.5 Buying and registering a license for instructions on how to enable all of 
Octaga Player’s features.

1.6 Open a file 
To open a file in Octaga Player, select Open from the File menu. Locate and select the 
file you want to display and press Open. 

Interactive 3D files normally have the file name extension .WRL for VRML files, or 
.X3D for X3D files.

You can also open files by simply dragging and dropping them into the player, or by 
double-clicking. In addition to X3D and VRML files, Octaga Player can also display 
video, image and audio files.

To view files located on the Internet, select Open Location from the File menu. In the 
dialog box, type the Internet address of the file you want to view.

If you want to open one of the presentations you have viewed recently, select Open 
Recent from the File menu and select from the displayed list.

If you don’t have a suitable 3D file, you can find some examples at Octaga’s web site, 
www.octaga.com, for example http://www.octaga.com/vrml/venus/venus.wrl.

1.7 A quick tour
In Octaga Player you navigate most of the time by clicking the left mouse button and 
dragging. You can drag forward, backward, right or left. These movements have 
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different effects in the various navigation modes, but we will get to that later.

If you don’t have a VRML or X3D file open yet, open one now. If you don’t have one 
stored on your computer, you should be able to find one with an Internet search, or at 
the Internet addresses in the preceding section.

When you have opened a 3D file you are ready to explore the virtual 3-dimensional 
world.

First, click the Fly button on the toolbar. Click and hold the left mouse button in the 
viewing area and move the mouse forward. You are now moving forward in the 3D 
world. While you are still holding the left mouse button depressed, move the mouse left 
or right. You now change the direction in which you are moving.

Try the different navigation modes. As you can see, clicking and dragging can have 
quite different effects in the various modes. You can also try holding down Ctrl or Shift 
keys while you click and drag. If you get lost, or stuck inside an object, press the Home 
button. This takes you back to the presentation’s starting point.

For in-depth information about navigating in Octaga Player, see section 4 Navigation.

1.8 Quit Octaga Player
To quit Octaga Player, select Exit from the File menu.

1.9 Buying and registering a license
Until you buy and register a license for Octaga Player, the program has the following 
limitations:

 The option window is displayed when you start the standalone player.
 Some of the advanced features are disabled. (See list below.)
 An Octaga logo is shown in the lower right hand corner of the display area.

In addition, you may only use the program for non-commercial purposes.

To remove these limitations, you need to buy and register a license.

To buy a license, click Buy Now in the option window. This will take you to Octaga’s 
web shop where you can buy your license. 

When you have bought the license you will get an e-mail confirming your purchase.

In the option window, click Register. Enter the required personal information and click 
Get Registration Key. You will receive a registration key by e-mail.

Copy the registration key from the e-mail and paste it into the registration dialog box 
and click Register Now. 

You can now enjoy the full functionality of Octaga Player, and you will no longer be 
bothered by the option window.
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1.9.1 Features that are disabled until you register
These are the features that are disabled until you buy and register a license for Octaga 
Player:
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4 Navigation
The term navigation, as used in Octaga Player, means moving around in the 3D scenes 
displayed in Octaga Player. Describing how to move in three dimensions with two-
dimensional tools is a bit of a challenge, and we tend to rely on terminology borrowed 
from aviation, such as roll, and from the film industry, such as zoom, tilt and pan.

Octaga presentations can offer pre-programmed animations and walkthroughs, as well 
as free navigation through the 3D world. The pre-programmed presentations usually 
offer their own user interface elements, such as buttons or menus, with which you can 
view the various parts of the presentation. You can, however, stop these animations and 
interact freely with the presented 3D scene.

1.10 Pointing devices 
To navigate freely in Octaga Player, you need a three-button mouse. This is not as 
exotic as it may sound. Most modern mice have a scrolling wheel, and when you press 
down on this wheel it works as the middle mouse button.

1.11 Navigation modes 
In Octaga Player there are five standard navigation modes: Walk, Fly, Examine, Slide 
and Look At. These modes are described in the following sections. In addition, other 
modes of navigation may be chosen through configuration. This is described in section 
7 Configuring the player. 

You can choose navigation modes by clicking the buttons on the toolbar, or by 
choosing the navigation mode you want from the Navigation menu. 

In all modes you can move faster by pressing the Shift key while you navigate. 

1.11.1 Basic navigation
Octaga Player offers a complete range of navigation methods, and these are all 
described in detail in the next section. But you can get around in a 3D scene with a 
simpler approach, just to get started: 

 In Walk mode, click with the left mouse button and drag forward and backward to 
move forward and backward along the surfaces in the scene.

Click with the left mouse button and drag to the left and right to turn left and right.

 In Fly mode, click with the left mouse button and drag forward and backward to 
move forward and backward in the scene.

Click with the left mouse button and drag to the left and right to turn left and right.

Fly mode is the same as Walk mode but without gravitation.

 In Examine mode, click with the left mouse button and drag forward and backward to 
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move around the scene on the horizontal axis.

Click with the left mouse button and drag to the left and right to move around the 
scene on the vertical axis.

 In Slide mode, click with the left mouse button and drag forward and backward to 
move up an down in the scene.

Click with the left mouse button and drag to the left and right to move left and right.

 In Look At mode, click on an object, then click with the left mouse button and drag 
forward and backward to move around the object on the horizontal axis.

Click with the left mouse button and drag to the left and right to move around the 
object on the vertical axis.

Look At mode is the same as Examine mode, except here you first select an object to 
examine before you navigate.

1.11.2 Walk mode
In Walk mode, you move in the direction you are looking, following the surfaces 
underneath you. It is like walking in the real world, with gravity and all. 
Keyboard shortcut: Ctrl+Alt+1
The following controls are available:

Mouse:
Left button: Move forward and backward, turn left and right
Ctrl + Left button: Move forward, backward, left and right
Middle button: Click on an object and move around it
Ctrl + Middle button: Tilt and pan
Mouse wheel: Tilt view up and down

Keyboard:
Arrow keys: Move forward, backward, left and right.

1.11.3 Fly mode 
In Fly mode, you move in the direction you are looking, independent of the surfaces 
underneath you. It is like Walk mode, but without the gravity. 
Keyboard shortcut: Ctrl+Alt+2
The following controls are available:

Mouse:
Left button: Move forward and backward, turn left and right
Ctrl + Left button: Move forward and backward, left and right
Alt + Left button: Move forward and backward, roll left and right
Middle button: Click on an object and move around it
Ctrl + Middle button: Tilt and pan
Alt + Middle button: Tilt and roll
Mouse wheel: Tilt view up and down

Keyboard:
Arrow keys: Move forward and backward, left and right
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1.11.4 Examine mode
In Examine mode, you move around the point where you click in the 3D scene. 
Keyboard shortcut: Ctrl+Alt+3
The following controls are available:

Mouse:
Left button: Move around the point where you click
Ctrl + Left button: Fly forward and backward, roll left and right
Middle button: Click on an object and move around it
Ctrl + Middle button: Move up and down, left and right
Alt + Middle button: Fly forward and backward, turn left and right
Mouse wheel: Zoom in and out

Keyboard:
Arrow keys: Rotate the object (or world) around the center of rotation.

1.11.5 Slide mode 
In Slide mode, you move up, down and sideways, while your angle of viewing stays the 
same. 
Keyboard shortcut: Ctrl+Alt+4
The following controls are available:

Mouse:
Left Button: Move up and down, left and right
Ctrl + Left button: Move forward and backward, turn left and right
Middle Button: Click on an object and move around it
Ctrl + Middle button: Tilt and pan
Mouse Wheel: Move forward and backward

Keyboard:
Arrow keys: Slide forward and backward, slide sideways

1.11.6 Look At mode 
In Look At mode you first select an object of interest by clicking on it. The view zooms 
in on the object you selected, and then you can study this object from all sides and 
angles. 
Keyboard shortcut: Ctrl+Alt+5
Click first, and then use any of the following controls:

Mouse:
Left button: Move around the selected object
Ctrl + Left button: Fly forward and backward, roll left and right
Middle button: Click on an object and move around it
Ctrl + Middle button: Move up and down, left and right
Alt + Middle button: Move forward and backward, turn left and right
Mouse wheel: Zoom in and out

Keyboard:
Arrow keys: Rotate the object (or world) around the center of rotation.
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1.12 Home
To get to the starting point of a presentation, press the Home button, or select Home 
from the Navigation menu. Keyboard shortcut: Ctrl + Alt + R. This is useful if you 
need to get your bearings in a 3D scene.

1.13 Collision detection
You can turn collision detection on and off by pressing the Collision button in the 
toolbar. Keyboard shortcut: Ctrl + Alt + C.

By default, collision detection is enabled in all navigation modes. This means that 
objects are solid, just as in the real world. When you turn collision detection off, you 
can move anywhere you like, such as through walls and inside objects.

1.14 Viewpoints
As you navigate a 3D scene, you can save viewpoints at any time. These viewpoints are 
stored in a separate file. You choose viewpoint functions from the Viewpoints menu, or 
from the menu which appears when you right click in the display area.

1.14.1 Saving viewpoints
To save a viewpoint, choose New Viewpoint from the Viewpoints menu. Keyboard 
shortcut: Ctrl + v. The viewpoints you save are added to the Viewpoints menu.

You can also export your viewpoints for later viewing of the same 3D file. To export 
your viewpoints, choose Export Viewpoints from the Viewpoints menu. Type in a name 
for the file and press OK. You should choose a file name which contains a reference to 
the presentation file, to ensure that you know which viewpoints file belongs to which 
presentation.

The next time you open the presentation for which you stored and saved viewpoints, 
you will notice that the viewpoints aren’t immediately available. This is because the 
viewpoints file is separate from the presentation file. To use your viewpoints you can 
either open the viewpoint file (files with an .ovf extension) instead of your presentation 
file, or open the presentation file first and then open the viewpoint file.

1.14.2 Viewpoint Tour
When you have made some viewpoints Octaga Player can take you on a tour through 
all of your viewpoints. Choose Viewpoint Tour from the Viewpoints menu. The 
viewpoints are shown in the order that you created them.

1.14.3 Next/Previous Viewpoint
You can move back and forth between the viewpoints you have made by choosing Go 
To from the Viewpoints menu, and then choosing Next or Previous from the sub-menu.
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5 Viewing options
In Octaga Player you can customize your view of the loaded 3D world to suit your 
preferences.

1.15 View All 
You can reposition the viewpoint so the entire 3D world fits on the screen by clicking 
the View All button in the toolbar. Keyboard shortcut: Ctrl + Alt + F 

1.16 Headlight
If you need more light, you can turn the headlight on by clicking the Headlight button 
in the toolbar. Click again to turn it off. Keyboard shortcut: Ctrl + Alt + H.

1.17 Fullscreen mode
To make the content fill your screen, click the Fullscreen button. Keyboard shortcut: 
Alt + Enter. 

To return to normal window mode, press the Escape key.

1.18 View menu
You can customize Octaga Player’s user interface in various ways with the functions on 
the View menu.

1.18.1 Toolbar
To hide or display the toolbar, select Toolbar from the View menu.

1.18.2 Status Bar
To hide or display the status bar, select Status Bar from the View menu.

1.18.3 Rendering mode
You can choose how to view your VRML content: 

 Vertices (dots)
 Wireframe
 Flat
 Smooth (the default)

To choose rendering mode, select Rendering from the View menu, and select the option 
you want from the sub-menu.
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1.19 Reload
To reload the current file into Octaga Player, click the Reload button.

1.20 Console window
The console window displays which files you have opened in Octaga Player, as well as 
warnings and error messages. To view the console window, select Console from the 
Tools menu.
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6 Recording
In Octaga Player you can record your navigation through the 3D scene. You can create 
videos directly, or create a series of single image files which can be processed offline 
and then combined into a video file. The recorded videos can be displayed in 
multimedia viewers, such as Windows Media Player. 

You can also make screenshot images of what is displayed in the player at any time.

Please note: The recording features are disabled until you buy a license and register 
your copy of Octaga Player.

1.21 Screenshot
To produce a single screenshot of what is displayed in Octaga Player, click the 
Screenshot button in the toolbar, choose Screenshot from the Recording menu, or press 
Ctrl + S. In the Select Image File Name dialog box, type a name for the image file and 
click Save.

1.22 Video settings
To configure your video settings, click the Video button in the toolbar, or select 
Recording Settings from the Recording menu. In the dialog box that appears, you can 
specify the properties of the video you want to record.

Video size: Choose the pixel resolution of the video. Use the standard settings from the 
drop-down menu or specify the number of pixels in the two input fields below.

You can also use the video size settings for single frame snapshots, and set the player 
window to be resized according to your settings.

Frame rate: Specify the number of frames per second. Broadcast quality video runs at 
25 frames per second, but if the video is going to be viewed on older equipment, a 
lower frame rate is recommended.

Numbered stills or AVI: Choose AVI video to produce a video, or numbered stills to 
produce a series of single frame images. These images may then be processed in other 
graphics applications for enhanced quality, before being linked together as video file.

Video Codec: If you want to make a video, you can choose among the various video 
codecs installed on your computer.

Image type: If you want to make a series of still images, you can choose either high 
quality TGA images or compressed JPEG images. 

If you choose JPEG images, you can use the variable setting. Choosing high quality 
settings make larger files, while smaller files give poorer image quality.

Output file(s): Specify the name of the video file you want to make, and where to store 
it. 
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If you are making still images, choose the folder in which to store your image files.

1.23 Recording video
To record video, click the Record button in the toolbar, choose Start Recording in the 
Recording menu, or press Ctrl + R.

1.24 Pause and restart recording
While you are recording, you may want to quickly go from one location to another in 
the world or model.

To pause video recording, click the Pause button in the toolbar, choose Pause 
Recording in the Recording menu, or press Ctrl + P.

To continue recording, press the Pause button again.

1.25 Stop recording
To stop recording video, press the Stop button in the toolbar, choose Stop Recording in 
the Recording menu, or press Ctrl + S.
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7 Configuring the player

1.26 Choosing options
The Octaga Player can be configured in the Options dialog box. To display the Options 
dialog box, choose Options from the Tools menu. The Options dialog box has six tabs: 
General, Rendering, Navigation, Audio, Performance and Optimization. On each tab 
you can set all values to their default settings by pressing the Default button. Press the 
Cancel button to cancel your adjustments or press the OK button to apply your changes.

1.26.1 General
When you click the General tab the following options are available: 

Wait for all resources: If some of the content needs to be downloaded from the Internet 
this check box determines if the player should wait for all resources to download (or 
fail) before displaying the content. Otherwise the 3D world will be loaded and textures, 
sound and other resources will appear after downloading is finished. Default is off.

Show detailed content warnings: Default is set to off. Enabling these warnings can be 
useful for debugging content files. The warnings are displayed in the Console window, 
which is accessible from the View menu.

Automatic check for updates: If this box is checked Octaga will check for updates on 
each start-up. Default is set to off.

Ignore invalid content: If this box is checked Octaga will not display content that is 
regarded as invalid. Default is set to on.

Strict standard conformance: If this box is checked Octaga will try to display 
everything in strict conformance with standards. Otherwise some non-standard 
optimizations and enhanced usability features are enabled. Default is set to on.

Max frames per second (FPS): Adjust the maximum number of frames per second by 
using the spinner, or by typing a new number in the text box. Default is set to 70 FPS. 
Use this setting to prevent Octaga Player from using more CPU than necessary.

File History Length: Adjust the number of recently loaded files to remember and 
display in the menu by using the spinner, or by typing a new number in the text box. 
Default is set to 5. 

Cache Size: Adjust the space reserved for caching remote content files. Default is set to 
50 000.

Clear Cache: Clear all the files currently stored in the cache. 

Use Octaga as your default 3D-player:
Use Octaga for VRML content: Click this button to use Octaga Player as your default 
VRML-player
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Use Octaga for X3D content: Click this button to use Octaga Player as your default 
X3D-player.

1.26.2 Rendering
When you click the Rendering tab the following options are available:

General rendering:
Max texture size: Use this setting to limit the maximum texture size. Large textures can 
cause performance problems if the total size of all textures exceed the amount of 
memory on your graphics card. Choose between 256x256, 512x512, 1024x1024 or 
hardware limit. Default is hardware limit.

Texture size rounding: If textures in use do not have a size that is of the format 2^n x 
2^m it will be resized by OpenGL. Use this setting to select whether to round down or 
to the nearest factor of n and m. Default is set to Down.

Max texture units: Use this option to control the maximum number of layered textures 
used in multi-texture nodes. Default is hardware limit.

Primitive resolution: Use this to control the resolution of the 3D primitives: box, cone, 
cylinder and sphere. The higher resolution the more polygons. Default is medium.

Text resolution: Use this to control the resolution of the 3D text. The higher resolution 
the more polygons. Default is medium.

Vertical Sync: Use this option to enable or disable vertical synchronization between 
rendering and monitor refresh rate.

OpenGL specific:
Antialiasing: Use this option to enable antialiasing. Antialiasing reduces the effect of 
jagged edges and provides in general a nicer rendered image. Antialiasing may lower 
the framerate as this is intensive for the graphics card. Default is off.

Antialiasing pr pixel: Use this setting to control the quality of the antialiasing. The 
higher number the smoother image but more rendering intensive. Default is 4.

Texture compression: Use this setting to enable texture compression in OpenGL. In 
general this enables the content to use more and bigger textures as they are compressed. 
The effect of this will differ among different graphics cards, as these have different 
amount of memory. Setting Texture compression on may display blurred images and 
other artifacts on some graphics cards. Default is on.

Separate specular color: Enable this feature to avoid blending the specular, or 
highlight, color with textures. Default is off.

Mip mapping: Use this option to control the level of mip mapping. Mip mapping gives 
nicer textures when textured objects are far away and improves performance. Default is 
standard.

Nurbs tesselation: Use this to control the way NURBS curves and surfaces are 
tesselated. Default is static.
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1.26.3 Navigation
When you click the Navigation tab the following options are avalable:

Use the Navigation style settings to set your preferred navigation style;
Octaga Style: Navigation as described in this document.
Strict VRML: Navigation according to the VRML standard.
Game Style: Navigation simulating a first person shooter. Try it!

Automatic center of rotation: This sets the center of rotation (in examine mode) to the 
estimated center of the objects in the 3D files you display. If unchecked, the center of 
rotation is the zero point of the displayed world.

1.26.4 Audio
When you click the Audio tab the following options are available:

Disable audio: Use this option to toggle sound on and off. Default is not disabled.

Mute when inactive: Mute the audio when the window is inactive. Default is off.

1.26.5 Visuals
When you click the Visuals tab the following options are available:

Performance vs Visual Quality: Drag the slider toward Performance or Quality, 
depending on what is important to you, and the capabilities of your computer.

If you want more detailed control, click the Use Advanced Rendering and Performance 
Settings checkbox. The Performance and Optimization tabs appear.

1.26.6 Performance
When you click the Performance tab the following options are available:

Performance VS visual quality:
Performance VS Quality: Use the slider to choose between 3 different set of 
preferences settings. The quality setting is an abstraction of all other settings that will 
improve visual quality. Selecting performance will set all settings that improve 
performance and speed. Default is the neutral setting which is a trade off between 
visual quality and performance.

Custom Settings: If individual settings are modified the Custom Settings checkbox will 
be checked and the performance slider will be disabled. Uncheck the Custom Settings 
box to clear the individual settings and use the slider.

1.26.7 Optimization
When you click the Optimization tab the following options are available:

Occlusion Culling:
Enabled: Enables or disables occlusion culling. Default is off.

Size Threshold: Objects bigger than this size will not be candidates for occlusion. 
Default is set to 0.3.
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Vertex Threshold: Objects with fever vertices than this will not be candidates for 
occlusion. Default is set to 1000.

Retest delay: The number of frames to wait, after a non-successful occlusion attempt, 
before retrying occlusion of the same object. Default is set to 5.

Small objects culling: 
Size Threshold:  Use the slider to control the level of objects regarded as small. Objects 
below this threshold will not be rendered. Default is set to 0.00.

Automatic framerate control: Default is off.

Target FPS: If you enable Automatic framerate control, you can specify your target 
frames per second (FPS) setting.

Use small object culling safe zone: If enabled, objects close to the viewpoint are not 
culled by small objects culling. Default is on.

Use geometry display lists: On some graphics cards, this may boost performance by 
allowing Octaga Player to use more memory. Default is off.

Use OpenGL Extensions: This can be disabled to check if rendering problems are 
caused by the OpenGL extensions. Default is on.

Use Compiled Vertex Arrays: This is a rendering performance option that may boost 
performance on some graphics hardware. However it might be disabled if causing 
trouble on your system. Default is on.

Use Hardware Mipmap Generation: This is a rendering performance option that may 
boost performance on some graphics hardware. However it might be disabled if causing 
trouble on your specific system. Default is on.

1.27 The configuration file 
Octaga Player can also be configured by modifying the configuration file. This file is in 
XML format, it is called OctagaConfig.xml and is located in the Config subdirectory in 
the Octaga player directory. On Windows systems the default location is: C:/Program 
Files/Octaga/Octaga Player/Config/OctagaPlayer.xml

The available options for use in the configuration file are available at:
http://www.octaga.com/doc/OctagaConfig.html

To see how this file is used, try modifying the settings using the preferences panel first 
and observe how the configured file is modified.
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8 Using the Octaga Player plug-in
Octaga Player can be used as a plug-in to Internet Explorer, Mozilla Firefox (and other 
Mozilla based web browsers), Opera, Microsoft Office and Adobe Acrobat. (Adobe 
Reader enabling pending). 

1.28  Using Octaga Player in Internet Explorer
Octaga Player will install itself as the default plug-in for VRML and X3D in Internet 
Explorer. If you install another player and you want to revert to using Octaga Player 
you can start Octaga Player in stand alone mode and choose Option->Preferences-
>General->”Use Octaga for VRML/X3D content”. For information on how to embed 
X3D/VRML content for display in Octaga Player see the developer page of the Octaga 
web site 
http://www.octaga.com/php/start.php?startpage=developer

1.29  Using Octaga Player in other web browsers
Octaga Player will install itself as a plugin for VRML and X3D in Firefox, Opera and 
all other browsers using the Netscape plugin system. If you already have another X3D/
VRML browser installed Octaga Player may not be the default player chosen by the 
web browser. See the web browser documentation for info on how to solve this. For 
information on how to embed X3D/VRML content for display in Octaga Player see the 
developer page of the Octaga web site 
http://www.octaga.com/php/start.php?startpage=developer

1.30  Using Octaga Player in Microsoft Office
Octaga Player can be used to display VRML/X3D content in all MS Office products 
(and other activeX capable programs). To insert the player in a document choose 
“insert object” select “Octaga Control” a dialog box will appear allowing you to choose 
the VRML/X3D url to display. 

1.31  Using Octaga Player in Adobe Acrobat
Octaga Player can be used to display PDF documents containing VRML/X3D content 
in Adobe Acrobat. For information on how to embed X3D/VRML in a PDF document 
see the developer page on the Octaga web site
http://www.octaga.com/php/start.php?startpage=developer
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9 Creating content

1.32  Creating VRML content
Octaga Player can display any file that conforms to the VRML standard. See the 
following link for specification and reference manual: 
http://www.web3d.org/x3d/specifications/vrml/index.html

1.33  Creating X3D content
In addition to the VRML Octaga Player supports most of the X3D standard. Octaga 
Player allows the use of X3D nodes in VRML and X3D files.

X3D specification can be found at:
http://www.web3d.org/x3d/specifications/x3d_specification.html

1.34  Creating Octaga specific extensions
Octaga supports the following extensions to the VRML/ /X3D standards:

1.34.1 Octaga nodes
Octaga Player also supports a set of Octaga specific nodes. A description of these nodes 
and their functionality can be found on the developer page of the Octaga web site.
http://www.octaga.com/php/start.php?startpage=developer

1.34.2 Extra script functionality
In addition to standard VRML/ECMA script the Octaga Player supports Octaga 
specific script methods and built in objects. A description of these methods and objects 
can be found on the developer page of the Octaga web site. 
http://www.octaga.com/php/start.php?startpage=developer

1.35  Debugging content files
While you are working on a presentation, the results displayed in Octaga Player may 
not always be what you expect. If you are having trouble with your presentation, it can 
be useful to see how Octaga Player interprets your file. You can export the presentation 
and compare the result to your original file and hopefully pinpoint the trouble.

To export a presentation from Octaga Player, select Export from the File menu 
(Keyboard shortcut Ctrl + E). Type in a file name and click Save.

You can also use this function to convert files between VRML and X3D format.

Octaga Player can give warnings when it encounters any problems in the content files. 
To see these warnings, enable Show detailed content warnings on the General tab in 
the Options dialog box, and then select View Console in the View menu.
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10 Keyboard shortcuts
The following keyboard shortcuts are available in Octaga Player and provide easier 
access to commonly used functions.

Ctrl + Alt + I to increase navigation speed
Ctrl + Alt + D to decrease navigation speed
Ctrl + Alt + R to reset viewpoint
Ctrl + Alt + G to toggle gravity on / off
Ctrl + Alt + C to toggle collision on / off
Ctrl + Alt + H to toggle headlight on / off
Ctrl + Alt + S to straighten up view
Ctrl + Alt + N to cycle between available navigation modes
Ctrl + Alt + M to cycle between graphics modes
Ctrl + Alt + F to fit model to window
Alt + Enter to go to fullscreen mode
Esc to exit fullscreen mode
Ctrl + S to save screenshot
Ctrl + R to start recording
Ctrl + P to pause recording
Ctrl + T to stop recording
Ctrl + V to record Viewpoints
F11 to go to the next Viewpoint
F12 to go to the previous viewpoint
PgUp to go to the next viewpoint
PgDn to go to the previous viewpoint
Home to go to the first viewpoint
End to go to the last viewpoint
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11 Getting help
The help menu provides access to help on using and configuring Octaga Player, in 
addition to other useful information.

1.36 Online manual 
Selecting Online Manual displays this reference manual.

1.37 World Information
To display information provided by the content authors about the VRML/X3D file 
currently loaded, select WorldInfo from the Tools menu. The window that appears also 
displays the file name.

1.38 System Information
To display information about your computer, select System Information from the Tools 
menu. This displays general information about your computer, and detailed information 
about your computer’s graphics system.

1.39 Check for updates
To check for updated versions of Octaga Player, select Check for updates from the 
Help menu. This checks the version number of the player you are using against the 
latest available version. If a newer version is available, you are directed to the 
download site.

1.40 About 
To display the About box, select About from the Help menu. This displays version 
number and copyright information for Octaga Player, as well as contact information for 
Octaga.
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12 Troubleshooting guide
This guide provides information on how to solve some common problems related to the 
installation and use of Octaga Player. If this information does not solve the problem, 
contact support@octaga.com for more help. For further contact information, see section 
13 Technical support below.

Unable to install Octaga Player If you are experiencing problems with 
installing the player, try uninstalling all 
previous versions of Octaga Player, check 
that your system timer is set correctly and try 
again.

General Display problems due to  
outdated drivers

Display problems have been experienced on 
some hardware using outdated graphics 
drivers.

Workaround:
Always use the latest graphic drivers made 
available form the graphics card vendor or 
notebook manufacturer.

Performance degradation on Dual  
Core systems with nVidia

Performance degradation has been 
experienced on Dual Core systems with 
nVidia graphic cards. 

Workaround:
Turn off OpenGL threading:
Open the NVIDIA Control Panel (New)
Select "3D Settings".
Select "Advanced View" from the toolbar.
Select "Manage 3D settings" under 
"Appearance".
Set the value of "OpenGL threading" to 
"Off".

Systems known to cause this problem:
Dual Core Systems with nVidia graphics

Display problems due to hardware 
mipmap generation

On some graphics hardware the hardware 
Mipmap generation has been known to cause 
display problems. 

Workaround:
Disable the use of Hardware Mipmap 
Generation (in the Option->Preferences-
>Optimization menu) to fix the problems.

Systems known to cause this problem:
ATI Radeon Mobility 9000

Display problems due to use of  
compiled vertex arrays

On some graphics hardware the use of 
compiled vertex arrays has been known to 
cause display problems. Workaround:
Disable the use of compiled vertex arrays (in 
the Option->Preferences->Optimization 
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menu) to fix the problems.

Systems known to cause this problem:
ATI Radeon Mobility7800 FireGL
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13 Technical support
Contact information:

Web: http://www.octaga.com 

Support: support@octaga.com 

Sales: sales@octaga.com 

Postal address:

OCTAGA AS
Sandakerveien 138
NO-0484 OSLO
NORWAY

Phone:  +47 90 51 91 76
Fax: +47 23 00 91 28

Office hours: 9:00 AM - 5:00 PM CET (GMT + 1)
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